Ganesha 4 :  Ganesha, Réussir votre dispositif e-learning Forum GANESHA v4

Propositions d'améliorations,
Discussions autour de l'utilisation pédagogique de Ganesha v4, SCORM, SCORM 2004, AICC, LOM, QTI, ...
Problèmes techniques (bug, installation, etc.)

 
Compatibilité PHP 5.3 ?
Envoyé par: xgen (---.rev.numericable.fr)
Date: mercredi 5 août 2009 13:38

Il semble d'après
le message de Sylvie (http://forum4.anemalab.org/read.php?2,1485) qu'il y ait un problème de compatibilité avec la
nouvelle version de PHP (PHP 5.3) qui sort des messages d'erreur "deprecated"

Et bien sûr avec les dernières versions de WAMP 2.0-i ou EasyPHP
qui ont adopté cette nouvelle version.

Quelle sont les implications, et les corrections ?



remarque du modérateur : pour rappel, le pré-requis PHP 5.2 :
[doc.ganesha.fr]



Modifié 1 fois. Dernière modification le 25/11/2014 16:59 par moderateur2.

Re: Compatibilité PHP 5.3
Envoyé par: evidianInstitute (129.184.84.---)
Date: jeudi 6 août 2009 16:30

J'appuie la question : après une période où j'ai un peu "customisé" la page d'accueil, je viens de tenter ma première connexion en tant que stagiaire et j'obtiens rien moins que 5 erreurs "deprecated" dont certaines sont bloquantes !!!

Ca concerne toujours l'assignation du retour de new par reference et des fonctions genre ereg_replace ou eregi_replace.



Modifié 2 fois. Dernière modification le 07/08/2009 10:01 par evidianInstitute.

Re: Compatibilité PHP 5.3
Envoyé par: Mehdi (Modérateur)
Date: lundi 10 août 2009 10:12

Bonjour,

La version 5.3 de PHP introduit de nombreux changements. Il n'est pas prévu de rendre la version 4.5 de Ganesha "compatible" avec cette version de PHP.

---

Mehdi pour l'équipe d'Anema.
Ganesha : plate-forme e-learning SCORM 2004

Re: Compatibilité PHP 5.3
Envoyé par: moderateur2 (Modérateur)
Date: lundi 10 août 2009 11:56

Mehdi a écrit:
-------------------------------------------------------
> La version 5.3 de PHP introduit de nombreux changements.

Un utilisateur sur le forum WampServer explique qu'il vaut mieux utiliser la version WampServer 2.0d pour bénéficier d'une version de PHP antérieure, compatible, tout en évitant les bugs des dernières versions plus récentes.

Re: Compatibilité PHP 5.3
Envoyé par: xgen (---.rev.numericable.fr)
Date: lundi 10 août 2009 15:53

J'ai fait plusieurs installations avec la version WampServer 2.0h
sans aucun problème.

Re: Compatibilité PHP 5.2
Envoyé par: moderateur2 (Modérateur)
Date: mercredi 2 juin 2010 17:25

En lien avec la discussion connexe sur PHP 5.2 :
[forum4.anemalab.org]
il me semble que la commande "SetEnv PHP_VER 5", voire "SetEnv PHP_VER 5.2" permet de s'assurer que le serveur est en PHP version 5.2
(et non 5.3, dont le code de version est 5_TEST )

Re: Compatibilité PHP 5.3
Envoyé par: bsavnet (---.u-bourgogne.fr)
Date: vendredi 21 octobre 2011 14:49

Hélas , depuis 2009 GANESHA est de moins ne moins utilisable . PHP 5.3 est partout et Ganesha 4.5 ne fonctionne pas. Je remarque que dans le code les les alertes pour les versions antérieures à la version 5.3 ont été désactivées . La php 5.3 met fin au fonctionnement de GAnesha 4.5.

Après 8 ans d'utilisation j'ai été obligé d'abandonner GANESHA sur mes sites interdroit.com et interdroit.net . Il existe un très bon produit qui remplace ,en libre Ganesha : EFront je peux expédier à qui le désire mon fichier "French".

B S

Re: Compatibilité PHP 5.3
Envoyé par: xgen (---.rev.numericable.fr)
Date: mercredi 2 novembre 2011 08:43

La compatibilité PHP 5.3 est possible.
Il y a un certain nombre de changements à faire.

Je vais préparer une version.

Re: Compatibilité PHP 5.3.x !
Envoyé par: moderateur2 (Modérateur)
Date: vendredi 16 mars 2012 13:57

Voici un installateur - en version béta - qui permet d'installer et d'utiliser Ganesha 4.5 avec PHP 5.3 :
[fad.ensg.eu]

PHP Version 5.3.10
Version de MySQL : 5.5.20
(le code a été utilisé sur un serveur Windows configuré à l'aide de WampServer 2.2d 32 bits)

Remarque : le code est aussi compatible avec PHP 5.2.0 et la version de MySQL : 5.5.8

Les modifications sont indiquées dans un fichier journal.txt

Prière de faire remonter les erreurs résiduelles.



Modifié 1 fois. Dernière modification le 19/03/2012 14:15 par moderateur2.

Re: Compatibilité PHP 5.3.x !
Envoyé par: o.ios (---.cylande.com)
Date: lundi 26 mars 2012 11:56

moderateur2 a écrit:
-------------------------------------------------------
> Voici un installateur - en version béta - qui
> permet d'installer et d'utiliser Ganesha 4.5 avec
> PHP 5.3 :
> [fad.ensg.eu]
>
> PHP Version 5.3.10
> Version de MySQL : 5.5.20
> (le code a été utilisé sur un serveur Windows
> configuré à l'aide de WampServer 2.2d 32 bits)
>
> Remarque : le code est aussi compatible avec PHP
> 5.2.0 et la version de MySQL : 5.5.8
>
> Les modifications sont indiquées dans un fichier
> journal.txt
>
> Prière de faire remonter les erreurs résiduelles.

super

merci bien

Olivier

Re: Compatibilité PHP 5.3
Envoyé par: nicoche (---.fbx.proxad.net)
Date: jeudi 17 mai 2012 22:51

Bonjour,

Je viens d'installer ganesha sur un serveur PHP 5.3.
J'ai eu les erreurs "deprecated"
J'ai donc installé la version de Ganesha 4.5.3.3 comme indiqué au dessus.

Mais à la fin de mon installation, j'ai ce message d'erreur :

"L'affichage des erreurs PHP est désactivée sur votre serveur, veuillez consulter le logs des erreurs pour obtenir davantage d'informations sur le problème rencontré."

Il y a t-il moyen de faire tourner correctement cette plateforme sur les serveurs actuels ?

Quelles sont les solutions?
D'avance, merci


Nicoche

Re: Compatibilité PHP 5.3
Envoyé par: moderateur2 (Modérateur)
Date: vendredi 18 mai 2012 16:46

nicoche a écrit :
-------------------------------------------------------
> L'affichage des erreurs PHP est désactivée sur votre serveur,
> veuillez consulter le logs des erreurs
> pour obtenir davantage d'informations sur le problème rencontré.

Avez-vous accès à ce fichier log ?

Par ailleurs, il y a des outils de diagnostic (voir dans la documentation :
[doc.ganesha.fr] )

Enfin, sinon, faites donc d'abord vos essais sur un serveur local - type WAMP - dont vous pourrez configurer facilement l'affichage des erreurs PHP.

Re: Compatibilité PHP 5.3
Envoyé par: nicoche (---.fbx.proxad.net)
Date: vendredi 18 mai 2012 17:37

J'ai downgradé ma version de PHP, c'était plus simple, merci de la réponse.

Re: Compatibilité PHP 5.3.x !
Envoyé par: rosariouser (---.fibertel.com.ar)
Date: jeudi 31 janvier 2013 18:35

Hello, I install version 5.3.3 . I have ONLY one problem with this Option::::
"PDF export of your training result",
This message appear:

Deprecated: Function set_magic_quotes_runtime() is deprecated in m/public_html/ganesha/fpdf/fpdf.php on line 923

Deprecated: Function set_magic_quotes_runtime() is deprecated in /public_html/ganesha/fpdf/fpdf.php on line 923

Deprecated: Function set_magic_quotes_runtime() is deprecated in /public_html/ganesha/fpdf/fpdf.php on line 1203
FPDF error: Some data has already been output, can't send PDF file

Re: PHP 5.3.x - set_magic_quotes_runtime() is deprecated
Envoyé par: moderateur2 (Modérateur)
Date: mercredi 6 février 2013 16:38

Re: PHP 5.3.x - set_magic_quotes_runtime() is deprecated

Please check the following information :
[ganesha-lms.eu]



Désolé, seuls les utilisateurs connectés peuvent envoyer des messages dans ce forum.
This forum powered by Phorum.