Ganesha 4 :  Ganesha, Réussir votre dispositif e-learning Forum GANESHA v4

Propositions d'améliorations,
Discussions autour de l'utilisation pédagogique de Ganesha v4, SCORM, SCORM 2004, AICC, LOM, QTI, ...
Problèmes techniques (bug, installation, etc.)

 
PB installation Ganesha sur serveur mutualisé 1and1
Envoyé par: sarloton (---.fbx.proxad.net)
Date: lundi 20 mai 2013 09:12

Bonjour

je souhaite installer la derniere version de ganesha (e-learning) pour nos élèves
et j'ai un probleme que je n'arrive pas à resoudre
il me fait une erreur à l'installation à chaque fois sur le serveur mutualisé 1and1:

pb avec magic quotes gpc à off et short open tag à on
pourtant j'ai bien mis php en version dev sur 1and1
j'ai essayé avec php en version 4 et en version dev (=5) sur 1and1 mais rien n'y fait
des que je lance (apres l'installation en forçant) , j'arrive bien sur ma page d'accueil mais avec des tas de lignes au dessus m'indiquant des erreurs de "magic quotes"
et les fonctions dates() ...

merci d'avance pour vos infos
Philippe

installation Ganesha sur serveur mutualisé 1and1
Envoyé par: Restapa (154.126.160.---)
Date: mardi 24 février 2015 10:26

Bonjour. Quand je suis la procedure d'installation de moodleen local sous windows 7, tout marche bien. cependant, sur mon damaine souscrit chez 1and1, l'installation est bloquée à la fin; en forçant, j'arrive bien sur ma page d'accueil mais avec des tas de lignes au dessus m'indiquant des erreurs de "magic quotes" et les fonctions dates() ...

Voici un extrait :

Deprecated: Function set_magic_quotes_runtime() is deprecated in /homepages/11/d563776949/htdocs/ganeshav4p5p3p2/ganesha/lib/library.lib.php on line 59

Strict Standards: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead in /homepages/11/d563776949/htdocs/ganeshav4p5p3p2/ganesha/inc/locales.inc.php on line 114

Strict Standards: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead in /homepages/11/d563776949/htdocs/ganeshav4p5p3p2/ganesha/inc/locales.inc.php on line 114

Strict Standards: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead in /homepages/11/d563776949/htdocs/ganeshav4p5p3p2/ganesha/inc/locales.inc.php on line 114

Strict Standards: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead in /homepages/11/d563776949/htdocs/ganeshav4p5p3p2/ganesha/inc/locales.inc.php on line 114

Strict Standards: Declaration of HTML_Form_ACL::addRow() should be compatible with HTML_Form::addRow($titre, $champ) in /homepages/11/d563776949/htdocs/ganeshav4p5p3p2/ganesha/html/html_form.php on line 1203

Strict Standards: Declaration of HTML_Page_Mail::MainMenu() should be compatible with HTML_Page::MainMenu($titre) in /homepages/11/d563776949/htdocs/ganeshav4p5p3p2/ganesha/html/html_page.php on line 877

Re: installation Ganesha sur serveur mutualisé 1and1
Envoyé par: moderateur2 (Modérateur)
Date: mardi 24 février 2015 14:32

Pour magic quotes , les archives du forum indiquent ceci :
[forum4.anemalab.org]

Re: installation Ganesha sur serveur mutualisé 1and1
Envoyé par: moderateur2 (Modérateur)
Date: mardi 24 février 2015 15:01

> Strict Standards: date()
> ./ganeshav4p5p3p2/ganesha/inc/locales.inc.php
> on line 114

D'après le message, il vaudrait mieux éditer la ligne correspondante dans ce fichier, pour y mettre la bonne valeur...
(ce qui demande quelque connaissance du langage PHP)


PS Sinon, quelle est la version PHP ?



Désolé, seuls les utilisateurs connectés peuvent envoyer des messages dans ce forum.
This forum powered by Phorum.